From: "Alexander Shiyan" <shc_work@mail.ru>
To: "Sascha Hauer" <s.hauer@pengutronix.de>
Cc: barebox@lists.infradead.org
Subject: Re[2]: [PATCH 3/5] GPIO: i.MX: Rewrite driver for using generic GPIO code
Date: Mon, 22 Apr 2013 13:23:24 +0400 [thread overview]
Message-ID: <1366622604.908846815@f78.mail.ru> (raw)
In-Reply-To: <20130422072152.GH32299@pengutronix.de>
> > > On Sat, Apr 20, 2013 at 08:18:50AM +0400, Alexander Shiyan wrote:
> > > >
> > > > Signed-off-by: Alexander Shiyan <shc_work@mail.ru>
> > > > ---
> > > > arch/arm/Kconfig | 1 -
> > > > drivers/gpio/Kconfig | 1 +
> > > > drivers/gpio/gpio-imx.c | 125 ++++++++++++------------------------------------
> > > > 3 files changed, 31 insertions(+), 96 deletions(-)
...
> > > > config GPIO_IMX
> > > > def_bool ARCH_IMX
> > > > + select GPIO_GENERIC
> > >
> > > I'm not convinced by this change. Indeed this makes for smaller
> > > sourcecode, but the binary gets over 1kb bigger. I think this is too
> > > much for no additional gain.
> >
> > The main idea of this change is reuse code if we can have multiple
> > targets in barebox. Probably, now is too early for this.
>
> Yeah, it may change once multiple gpio drivers are compiled into the
> binary.
>
> BTW maybe you can lower the impact of the generic gpio driver by making
> the basic-mmio-gpio platform driver optional. It is not used by the i.MX
> part.
"basic-mmio-gpio" driver is a part of generic GPIO but it is already
a separate config symbol GPIO_GENERIC_PLATFORM.
In any case I will think about optimization this code.
---
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2013-04-22 9:23 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-20 4:18 [PATCH 1/5] GPIO: Rename "drivers/gpio.c" to "drivers/gpiolib.c" Alexander Shiyan
2013-04-20 4:18 ` [PATCH] ubimkvol: Typo fix Alexander Shiyan
2013-04-20 4:18 ` [PATCH 2/5] ARM: i.MX: Move GPIO driver to drivers/gpio Alexander Shiyan
2013-04-20 4:18 ` [PATCH 3/5] GPIO: i.MX: Rewrite driver for using generic GPIO code Alexander Shiyan
2013-04-22 6:46 ` Sascha Hauer
2013-04-22 6:59 ` Re[2]: " Alexander Shiyan
2013-04-22 7:21 ` Sascha Hauer
2013-04-22 9:23 ` Alexander Shiyan [this message]
2013-04-20 4:18 ` [PATCH 4/5] GPIO: i.MX: Cleanup driver code Alexander Shiyan
2013-04-20 17:04 ` Jean-Christophe PLAGNIOL-VILLARD
2013-04-22 16:58 ` Sascha Hauer
2013-04-20 4:18 ` [PATCH 5/5] Introduce coredevice_platform_driver() macro and use it for GPIO drivers Alexander Shiyan
2013-04-22 16:59 ` [PATCH 1/5] GPIO: Rename "drivers/gpio.c" to "drivers/gpiolib.c" Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1366622604.908846815@f78.mail.ru \
--to=shc_work@mail.ru \
--cc=barebox@lists.infradead.org \
--cc=s.hauer@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox