mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* hush patches
@ 2013-11-12 13:52 Sascha Hauer
  2013-11-12 13:52 ` [PATCH 01/10] hush: fix exit on syntax error behaviour Sascha Hauer
                   ` (9 more replies)
  0 siblings, 10 replies; 11+ messages in thread
From: Sascha Hauer @ 2013-11-12 13:52 UTC (permalink / raw)
  To: barebox

This contains several hush cleanup patches I came across while trying
to fix the weird behaviour that an interactive hush currently exits
on a syntax error. This is fixed and also we now get a nice
'syntax error: unexpected token `x'' in some cases. Hopefully no other
functional changes introduced.

----------------------------------------------------------------
Sascha Hauer (10):
      hush: fix exit on syntax error behaviour
      hush: refactor readline call
      readline: remove unused variable
      hush: refactor get_user_input()
      hush: refactor file_get()
      hush: rename __promptme to interrupt
      consolidate syntax() and syntax_err()
      hush: Be more informative on syntax error
      hush: use standard ARRAY_SIZE
      hush: refactor reserved_word()

 common/hush.c  | 188 ++++++++++++++++++++++++++++++++-------------------------
 lib/readline.c |   3 +-
 2 files changed, 108 insertions(+), 83 deletions(-)

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2013-11-12 13:52 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-11-12 13:52 hush patches Sascha Hauer
2013-11-12 13:52 ` [PATCH 01/10] hush: fix exit on syntax error behaviour Sascha Hauer
2013-11-12 13:52 ` [PATCH 02/10] hush: refactor readline call Sascha Hauer
2013-11-12 13:52 ` [PATCH 03/10] readline: remove unused variable Sascha Hauer
2013-11-12 13:52 ` [PATCH 04/10] hush: refactor get_user_input() Sascha Hauer
2013-11-12 13:52 ` [PATCH 05/10] hush: refactor file_get() Sascha Hauer
2013-11-12 13:52 ` [PATCH 06/10] hush: rename __promptme to interrupt Sascha Hauer
2013-11-12 13:52 ` [PATCH 07/10] consolidate syntax() and syntax_err() Sascha Hauer
2013-11-12 13:52 ` [PATCH 08/10] hush: Be more informative on syntax error Sascha Hauer
2013-11-12 13:52 ` [PATCH 09/10] hush: use standard ARRAY_SIZE Sascha Hauer
2013-11-12 13:52 ` [PATCH 10/10] hush: refactor reserved_word() Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox