mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sascha Hauer <s.hauer@pengutronix.de>
To: barebox@lists.infradead.org
Subject: [PATCH] persistent device names for console devices
Date: Fri, 11 Jul 2014 10:02:09 +0200	[thread overview]
Message-ID: <1405065733-31407-1-git-send-email-s.hauer@pengutronix.de> (raw)

Currently the console devices have arbitrary cs0..csx names
which makes them hard to find on the commandline and in scripts.
This series introduces persistent names for console devices and
renames the network console to "netconsole" and the usb serial
console to "usbserial"

Sascha

The following changes since commit 239b6559ed5d65cc3e08eae66eb862fefe651e33:

  images: ignore and clean *.mlo/*.mlospi (2014-07-11 08:27:01 +0200)

are available in the git repository at:

  none 

for you to fetch changes up to c053e2414c2a6c2de81cbbc4e49933042613191b:

  usb: usbserial gadget: Add persistent device name (2014-07-11 09:58:53 +0200)

----------------------------------------------------------------
Sascha Hauer (4):
      console: Allow persistent device names
      serial: imx: Determine device name from device tree
      netconsole: rename console to "netconsole"
      usb: usbserial gadget: Add persistent device name

 common/console.c              | 10 ++++++++--
 drivers/serial/serial_imx.c   |  4 ++++
 drivers/usb/gadget/u_serial.c |  7 ++++++-
 include/console.h             |  2 ++
 net/netconsole.c              |  1 +
 5 files changed, 21 insertions(+), 3 deletions(-)

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

             reply	other threads:[~2014-07-11  8:02 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-07-11  8:02 Sascha Hauer [this message]
2014-07-11  8:02 ` [PATCH 1/4] console: Allow persistent device names Sascha Hauer
2014-07-11  8:02 ` [PATCH 2/4] serial: imx: Determine device name from device tree Sascha Hauer
2014-07-11  8:02 ` [PATCH 3/4] netconsole: rename console to "netconsole" Sascha Hauer
2014-07-11  8:02 ` [PATCH 4/4] usb: usbserial gadget: Add persistent device name Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1405065733-31407-1-git-send-email-s.hauer@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox