From: Juergen Beisert <jbe@pengutronix.de>
To: barebox@lists.infradead.org
Subject: Re: [PATCH 3/6] mci: rename trans_speed field to csd_max_dtr
Date: Fri, 31 May 2013 09:35:41 +0200 [thread overview]
Message-ID: <201305310935.41387.jbe@pengutronix.de> (raw)
In-Reply-To: <1369984443-8790-3-git-send-email-s.hauer@pengutronix.de>
Sascha Hauer wrote:
> tran_speed is confusing since the name doesn't tell us if this
> is the maximum speed, the current speed or whatever else. Rename
> it to csd_max_dtr since this variable holds the maximum data transfer
> rate we extracted from csd.
>
> Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
> ---
> drivers/mci/mci-core.c | 4 ++--
> include/mci.h | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/mci/mci-core.c b/drivers/mci/mci-core.c
> index 895108f..d7b8fc9 100644
> --- a/drivers/mci/mci-core.c
> +++ b/drivers/mci/mci-core.c
> @@ -779,8 +779,8 @@ static void mci_extract_max_tran_speed_from_csd(struct mci *mci)
> return;
> }
>
> - mci->tran_speed = time * unit;
> - dev_dbg(&mci->dev, "Transfer speed: %u\n", mci->tran_speed);
> + mci->csd_max_dtr = time * unit;
> + dev_dbg(&mci->dev, "Transfer speed: %u\n", mci->csd_max_dtr);
> }
>
> /**
> diff --git a/include/mci.h b/include/mci.h
> index 1eb967d..2b87691 100644
> --- a/include/mci.h
> +++ b/include/mci.h
> @@ -340,7 +340,7 @@ struct mci {
> unsigned csd[4]; /**< card's "card specific data register" */
> unsigned cid[4]; /**< card's "card identification register" */
> unsigned short rca; /* FIXME */
> - unsigned tran_speed; /**< not yet used */
> + unsigned csd_max_dtr; /**< max data transfer rate as decoded from csd */
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
\o/ \o/ \o/ ;)
> /** currently used data block length for read accesses */
> unsigned read_bl_len;
> /** currently used data block length for write accesses */
Acked-by: Juergen Beisert <jbe@pengutronix.de>
jbe
--
Pengutronix e.K. | Juergen Beisert |
Linux Solutions for Science and Industry | http://www.pengutronix.de/ |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2013-05-31 7:37 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-05-31 7:13 [PATCH 1/6] mci: print current clock in info Sascha Hauer
2013-05-31 7:13 ` [PATCH 2/6] mci: do not limit clock to card capabilities Sascha Hauer
2013-05-31 7:30 ` Juergen Beisert
2013-05-31 7:14 ` [PATCH 3/6] mci: rename trans_speed field to csd_max_dtr Sascha Hauer
2013-05-31 7:35 ` Juergen Beisert [this message]
2013-05-31 7:14 ` [PATCH 4/6] mci: Use csd_max_dtr when appropriate Sascha Hauer
2013-05-31 7:37 ` Juergen Beisert
2013-05-31 7:14 ` [PATCH 5/6] mci: Add devicetree helper function Sascha Hauer
2013-05-31 7:14 ` [PATCH 6/6] mci: i.MX esdhc: get additional parameters from devicetree Sascha Hauer
2013-05-31 7:33 ` [PATCH 1/6] mci: print current clock in info Juergen Beisert
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201305310935.41387.jbe@pengutronix.de \
--to=jbe@pengutronix.de \
--cc=barebox@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox