From: Sascha Hauer <s.hauer@pengutronix.de>
To: Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 13/22] OF: base: import parent/child functions from Linux OF API
Date: Tue, 18 Jun 2013 22:29:31 +0200 [thread overview]
Message-ID: <20130618202931.GC32299@pengutronix.de> (raw)
In-Reply-To: <1371576607-8090-14-git-send-email-sebastian.hesselbarth@gmail.com>
On Tue, Jun 18, 2013 at 07:29:58PM +0200, Sebastian Hesselbarth wrote:
> This imports of_get_parent, of_get_next_child, of_get_next_available_child,
> and of_get_child_by_name and corresponding helpers from Linux OF API.
>
> Signed-off-by: Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
> ---
> Cc: barebox@lists.infradead.org
> ---
> drivers/of/base.c | 78 +++++++++++++++++++++++++++++++++++++++++++++++++++++
> include/of.h | 49 +++++++++++++++++++++++++++++++++
> 2 files changed, 127 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/of/base.c b/drivers/of/base.c
> index 148f832..17364ea 100644
> --- a/drivers/of/base.c
> +++ b/drivers/of/base.c
> @@ -862,6 +862,84 @@ int of_device_is_available(const struct device_node *device)
> }
> EXPORT_SYMBOL(of_device_is_available);
>
> +/**
> + * of_get_parent - Get a node's parent if any
> + * @node: Node to get parent
> + *
> + * Returns a pointer to the parent node or NULL if already at root.
> + */
> +struct device_node *of_get_parent(const struct device_node *node)
> +{
> + if (!node)
> + return NULL;
> +
> + return (node == root_node) ? NULL : node->parent;
> +}
> +EXPORT_SYMBOL(of_get_parent);
> +
> +/**
> + * of_get_next_child - Iterate a node childs
> + * @node: parent node
> + * @prev: previous child of the parent node, or NULL to get first
> + *
> + * Returns a pointer to the next child or NULL.
> + */
> +struct device_node *of_get_next_child(const struct device_node *node,
> + struct device_node *prev)
> +{
> + if (!node)
> + return NULL;
> +
> + if (!prev)
> + return list_prepare_entry(prev, &node->children, parent_list);
> +
> + list_for_each_entry_continue(prev, &node->children, parent_list)
> + return prev;
> +
> + return NULL;
> +}
> +EXPORT_SYMBOL(of_get_next_child);
> +
> +/**
> + * of_get_next_available_child - Find the next available child node
> + * @node: parent node
> + * @prev: previous child of the parent node, or NULL to get first
> + *
> + * This function is like of_get_next_child(), except that it
> + * automatically skips any disabled nodes (i.e. status = "disabled").
> + */
> +struct device_node *of_get_next_available_child(const struct device_node *node,
> + struct device_node *prev)
> +{
> + for_each_child_of_node(node, prev)
> + if (of_device_is_available(prev))
> + return prev;
> + return NULL;
> +}
> +EXPORT_SYMBOL(of_get_next_available_child);
> +
> +/**
> + * of_get_child_by_name - Find the child node by name for a given parent
> + * @node: parent node
> + * @name: child name to look for.
> + *
> + * This function looks for child node for given matching name
> + *
> + * Returns a node pointer if found or NULL.
> + */
> +struct device_node *of_get_child_by_name(const struct device_node *node,
> + const char *name)
> +{
> + struct device_node *child;
> +
> + for_each_child_of_node(node, child)
> + if (child->name && (of_node_cmp(child->name, name) == 0))
> + return child;
> +
> + return NULL;
> +}
> +EXPORT_SYMBOL(of_get_child_by_name);
> +
> void of_print_nodes(struct device_node *node, int indent)
> {
> struct device_node *n;
> diff --git a/include/of.h b/include/of.h
> index 208b00b..c69b9ad 100644
> --- a/include/of.h
> +++ b/include/of.h
> @@ -195,6 +195,14 @@ extern struct device_node *of_find_node_with_property(
> struct device_node *from, const char *prop_name);
> extern int of_device_is_available(const struct device_node *device);
>
> +extern struct device_node *of_get_parent(const struct device_node *node);
> +extern struct device_node *of_get_next_child(const struct device_node *node,
> + struct device_node *prev);
> +extern struct device_node *of_get_next_available_child(
> + const struct device_node *node, struct device_node *prev);
> +extern struct device_node *of_get_child_by_name(const struct device_node *node,
> + const char *name);
> +
> extern void of_alias_scan(void);
> extern int of_alias_get_id(struct device_node *np, const char *stem);
> extern const char *of_alias_get(struct device_node *np);
> @@ -239,6 +247,29 @@ static inline struct device_node *of_get_root_node(void)
> return NULL;
> }
>
> +static inline struct device_node *of_get_parent(const struct device_node *node)
> +{
> + return NULL;
> +}
> +
> +static inline struct device_node *of_get_next_child(
> + const struct device_node *node, struct device_node *prev)
> +{
> + return NULL;
> +}
> +
> +static inline struct device_node *of_get_next_available_child(
> + const struct device_node *node, struct device_node *prev)
> +{
> + return NULL;
> +}
> +
> +static inline struct device_node *of_get_child_by_name(
> + const struct device_node *node, const char *name)
> +{
> + return NULL;
> +}
> +
> static inline struct property *of_find_property(const struct device_node *np,
> const char *name,
> int *lenp)
> @@ -321,4 +352,22 @@ static inline struct device_node *of_find_matching_node(
> for (dn = of_find_node_with_property(NULL, prop_name); dn; \
> dn = of_find_node_with_property(dn, prop_name))
>
> +#define for_each_child_of_node(parent, child) \
> + for (child = of_get_next_child(parent, NULL); child != NULL; \
> + child = of_get_next_child(parent, child))
Why don't we just rename the original list iteration #define?
I think we shouldn't generate worse code just for the sake of being in
sync with Linux.
I wonder why the Linux implementation doesn't use the Linux list
implementation...
Sascha
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2013-06-18 20:29 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-18 17:29 [PATCH 00/22] Barebox OF API fixes, sync, and cleanup Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 01/22] lib: string: import case-insensitive string compare Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 02/22] OF: base: bail out early on missing matches for of_match_node Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 03/22] OF: base: also update property length on of_property_write_u32 Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 04/22] OF: base: export of_alias_scan Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 05/22] OF: base: convert strcmp to default string compare functions Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 06/22] OF: base: sync of_find_property with linux OF API Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 07/22] OF: base: sync of_find_node_by_path " Sebastian Hesselbarth
2013-06-18 20:13 ` Sascha Hauer
2013-06-18 20:19 ` Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 08/22] OF: base: rename of_node_disabled to of_device_is_available Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 09/22] OF: base: import of_find_node_by_name from Linux OF API Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 10/22] OF: base: import of_find_compatible_node " Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 11/22] OF: base: import of_find_matching_node_and_match " Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 12/22] OF: base: import of_find_node_with_property " Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 13/22] OF: base: import parent/child functions " Sebastian Hesselbarth
2013-06-18 20:18 ` Sascha Hauer
2013-06-18 20:29 ` Sascha Hauer [this message]
2013-06-18 20:34 ` Sebastian Hesselbarth
2013-06-18 17:29 ` [PATCH 14/22] OF: base: import of_property_read_* helpers " Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 15/22] OF: base: import of_parse_phandle " Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 16/22] OF: base: import parse phandle functions " Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 17/22] OF: base: introduce property write for bool, u8, u16, and u64 Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 18/22] OF: base: import property iterators from Linux OF API Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 19/22] OF: base: remove of_tree_for_each_node from public API Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 20/22] OF: base: remove of_find_child_by_name Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 21/22] OF: base: convert and remove device_node_for_nach_child Sebastian Hesselbarth
2013-06-18 17:30 ` [PATCH 22/22] OF: base: cleanup base function include Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 00/22] Barebox OF API fixes, sync, and cleanup Sebastian Hesselbarth
2013-06-20 9:18 ` Sascha Hauer
2013-06-19 9:09 ` [PATCH v2 01/22] lib: string: import case-insensitive string compare Sebastian Hesselbarth
2013-06-20 9:04 ` Sascha Hauer
2013-06-19 9:09 ` [PATCH v2 02/22] OF: base: bail out early on missing matches for of_match_node Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 03/22] OF: base: also update property length on of_property_write_u32 Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 04/22] OF: base: export of_alias_scan Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 05/22] OF: base: convert strcmp to default string compare functions Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 06/22] OF: base: sync of_find_property with linux OF API Sebastian Hesselbarth
2013-06-20 8:57 ` Sascha Hauer
2013-06-19 9:09 ` [PATCH v2 07/22] OF: base: sync of_find_node_by_path " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 08/22] OF: base: rename of_node_disabled to of_device_is_available Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 09/22] OF: base: import of_find_node_by_name from Linux OF API Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 10/22] OF: base: import of_find_compatible_node " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 11/22] OF: base: import of_find_matching_node_and_match " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 12/22] OF: base: import of_find_node_with_property " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 13/22] OF: base: import parent/child functions " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 14/22] OF: base: import of_property_read_* helpers " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 15/22] OF: base: import of_parse_phandle " Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 16/22] OF: base: import parse phandle functions " Sebastian Hesselbarth
2013-06-20 8:33 ` Sascha Hauer
2013-06-19 9:09 ` [PATCH v2 17/22] OF: base: introduce property write for bool, u8, u16, and u64 Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 18/22] OF: base: import property iterators from Linux OF API Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 19/22] OF: base: remove of_tree_for_each_node from public API Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 20/22] OF: base: remove of_find_child_by_name Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 21/22] OF: base: convert and remove device_node_for_nach_child Sebastian Hesselbarth
2013-06-19 9:09 ` [PATCH v2 22/22] OF: base: cleanup base function include Sebastian Hesselbarth
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130618202931.GC32299@pengutronix.de \
--to=s.hauer@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=sebastian.hesselbarth@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox