From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
To: barebox@lists.infradead.org
Subject: [PATCH 0/9 v4] prepare for rsa support
Date: Tue, 17 Mar 2015 12:49:23 +0100 [thread overview]
Message-ID: <20150317114923.GQ26127@ns203013.ovh.net> (raw)
Hi,
The following patch series prepare for the adding of the rsa digest
support
This will allow to verify a rsa signature of a file
Introduction of a new command digest to handle the digest and check
The next patch series will add RSA and keystore support
v2:
- rebase on next
- add pbkdf2 to password/login framework
- command allow to have runtime output
used it in the new digest to print the supported algo
v3:
add more fix to ensure all the digest_xx call return are checked
v4:
- drop key params for digest_file_window/digest_file/digest_file_by_name
- digest improve help
please pull
The following changes since commit bbba2d05585637d04657dce293c0cb0611dbfeea:
Merge branch 'for-next/state' into next (2015-03-13 08:32:38 +0100)
are available in the git repository at:
git://git.jcrosoft.org/barebox.git delivery/digest
for you to fetch changes up to 50b6b7d02eb109ba2807c2bb6e740fa01cdedc24:
command: add generic digest command (2015-03-15 06:28:34 +0800)
----------------------------------------------------------------
Jean-Christophe PLAGNIOL-VILLARD (9):
crypto: digest: digest_file_window: check every digest_xxx return
crypto: digest: digest_file_window/digest_file/digest_file_by_name drop key params
digest: add verify callback
digest: add digest callback
crypto: hmac: use digest_digest and check the return of every digest_xxx
crypto: add pbkdf2 hmac key generator
command: allow runtime usage
command: rename digest.c to hashsum.c
command: add generic digest command
commands/Kconfig | 26 ++++++++++++------
commands/Makefile | 3 ++-
commands/digest.c | 283 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-------------------------------------------------------------------------------------------------------
commands/hashsum.c | 187 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
commands/internal.h | 3 +++
common/command.c | 2 ++
crypto/Kconfig | 5 ++++
crypto/Makefile | 2 ++
crypto/digest.c | 81 +++++++++++++++++++++++++++++++++++++++++++++----------
crypto/hmac.c | 51 ++++++++++++++++++++++-------------
crypto/internal.h | 4 +++
crypto/md5.c | 2 ++
crypto/pbkdf2.c | 94 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
crypto/sha1.c | 2 ++
crypto/sha2.c | 3 +++
crypto/sha4.c | 3 +++
include/command.h | 3 +++
include/crypto/pbkdf2.h | 23 ++++++++++++++++
include/digest.h | 25 +++++++++++++----
19 files changed, 603 insertions(+), 199 deletions(-)
create mode 100644 commands/hashsum.c
create mode 100644 commands/internal.h
create mode 100644 crypto/pbkdf2.c
create mode 100644 include/crypto/pbkdf2.h
Best Regards,
J.
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next reply other threads:[~2015-03-17 11:49 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-17 11:49 Jean-Christophe PLAGNIOL-VILLARD [this message]
2015-03-17 11:53 ` [PATCH 1/9] crypto: digest: digest_file_window: check every digest_xxx return Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 2/9] crypto: digest: digest_file_window/digest_file/digest_file_by_name drop key params Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 3/9] digest: add verify callback Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 4/9] digest: add digest callback Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 5/9] crypto: hmac: use digest_digest and check the return of every digest_xxx Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 6/9] crypto: add pbkdf2 hmac key generator Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 7/9] command: allow runtime usage Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 8/9] command: rename digest.c to hashsum.c Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 11:53 ` [PATCH 9/9] command: add generic digest command Jean-Christophe PLAGNIOL-VILLARD
2015-03-17 12:54 ` [PATCH 0/9 v4] prepare for rsa support Jan Lübbe
2015-03-18 7:44 ` Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150317114923.GQ26127@ns203013.ovh.net \
--to=plagnioj@jcrosoft.com \
--cc=barebox@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox