From: Sascha Hauer <s.hauer@pengutronix.de>
To: Marc Kleine-Budde <mkl@pengutronix.de>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 3/5] timeout: factor out wait-for-key-press loop into separate file
Date: Mon, 20 Apr 2015 13:13:02 +0200 [thread overview]
Message-ID: <20150420111302.GN6325@pengutronix.de> (raw)
In-Reply-To: <1429519419-20325-3-git-send-email-mkl@pengutronix.de>
On Mon, Apr 20, 2015 at 10:43:37AM +0200, Marc Kleine-Budde wrote:
> This patch factors out the wait-for-key-press loop from the shell command
> "timeout" into a sparate file, so that it can be used from C, too.
>
> Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
> ---
> commands/Kconfig | 1 +
> commands/timeout.c | 62 ++++++++++-----------------------------------
> common/Kconfig | 3 +++
> common/Makefile | 1 +
> common/simple_timeout.c | 66 ++++++++++++++++++++++++++++++++++++++++++++++++
> include/simple_timeout.h | 11 ++++++++
> 6 files changed, 95 insertions(+), 49 deletions(-)
> create mode 100644 common/simple_timeout.c
> create mode 100644 include/simple_timeout.h
>
> diff --git a/commands/Kconfig b/commands/Kconfig
> index 847ff76d1d8b..1c9083381fac 100644
> --- a/commands/Kconfig
> +++ b/commands/Kconfig
> @@ -1487,6 +1487,7 @@ config CMD_READLINE
> config CMD_TIMEOUT
> tristate
> prompt "timeout"
> + select SIMPLE_TIMEOUT
Since the linker throws away unused functions anyway I think we don't
need an option for this.
> +#include <clock.h>
> +#include <command.h>
> +#include <errno.h>
> +#include <simple_timeout.h>
> +#include <stdio.h>
> +
> +int is_simple_timeout(int timeout_s, unsigned flags, char *out_key)
I don't like the name very much since we already have a is_timeout
function which does something completely different. Also is_xxx_timeout
seems to imply that this function doesn't wait but only returns a
status.
How about console_countdown() or similar?
Sascha
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2015-04-20 11:13 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-20 8:43 [PATCH 1/5] command: timeout: remove unhandled '-t' option Marc Kleine-Budde
2015-04-20 8:43 ` [PATCH 2/5] command: timeout: add documentation for option '-v' Marc Kleine-Budde
2015-04-20 8:43 ` [PATCH 3/5] timeout: factor out wait-for-key-press loop into separate file Marc Kleine-Budde
2015-04-20 11:13 ` Sascha Hauer [this message]
2015-04-22 7:49 ` Marc Kleine-Budde
2015-04-22 8:23 ` Sascha Hauer
2015-04-22 8:27 ` Marc Kleine-Budde
2015-04-20 8:43 ` [PATCH 4/5] ubi: cdev: remove trailing newline from debug messages Marc Kleine-Budde
2015-04-20 8:43 ` [PATCH 5/5] of_path: of_find_path(): add possibility to return .bb device Marc Kleine-Budde
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150420111302.GN6325@pengutronix.de \
--to=s.hauer@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=mkl@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox