mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sascha Hauer <s.hauer@pengutronix.de>
To: Andrey Smirnov <andrew.smirnov@gmail.com>
Cc: Barebox List <barebox@lists.infradead.org>
Subject: Re: [PATCH v2 01/19] ARM: i.MX: boot: Coalesce copy-pasted code
Date: Wed, 18 Apr 2018 10:15:15 +0200	[thread overview]
Message-ID: <20180418081515.fdusp7fvycmq7kij@pengutronix.de> (raw)
In-Reply-To: <CAHQ1cqF3sXJ2-FiK8vHnMswns+fE=dad=xqaTONmC9z63Sr1cg@mail.gmail.com>

On Tue, Apr 17, 2018 at 08:20:46AM -0700, Andrey Smirnov wrote:
> On Mon, Apr 16, 2018 at 11:58 PM, Sascha Hauer <s.hauer@pengutronix.de> wrote:
> > On Mon, Apr 16, 2018 at 12:31:39PM -0700, Andrey Smirnov wrote:
> >> All of the instances of imx*_boot_save_loc() do exactly the same thing with
> >> the only difference being SoC-specific imx*_get_boot_source
> >> call. Convert the code into a generic function taking function pointer
> >> + a macro to take care of the boilerplate.
> >>
> >> Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
> >> ---
> >>  arch/arm/mach-imx/boot.c | 85 ++++++++++--------------------------------------
> >>  1 file changed, 17 insertions(+), 68 deletions(-)
> >>
> >> +imx_boot_save_loc(void (*get_boot_source)(enum bootsource *, int *))
> >>  {
> >>       enum bootsource src = BOOTSOURCE_UNKNOWN;
> >>       int instance = BOOTSOURCE_INSTANCE_UNKNOWN;
> >>
> >> -     imx7_get_boot_source(&src, &instance);
> >> +     get_boot_source(&src, &instance);
> >>
> >>       bootsource_set(src);
> >>       bootsource_set_instance(instance);
> >>  }
> >> +
> >> +#define IMX_BOOT_SAVE_LOC(soc)                                       \
> >> +     void soc##_boot_save_loc(void)                          \
> >> +     {                                                       \
> >> +             imx_boot_save_loc(soc##_get_boot_source);       \
> >> +     }
> >> +
> >> +IMX_BOOT_SAVE_LOC(imx25)
> >> +IMX_BOOT_SAVE_LOC(imx27)
> >> +IMX_BOOT_SAVE_LOC(imx35)
> >> +IMX_BOOT_SAVE_LOC(imx51)
> >> +IMX_BOOT_SAVE_LOC(imx53)
> >> +IMX_BOOT_SAVE_LOC(imx6)
> >> +IMX_BOOT_SAVE_LOC(imx7)
> >
> > I do not really like this patch. Yes, it saves a few lines of code, but
> > with the cost of making it less readable.
> >
> 
> Can you elaborate on what part is less readable? IMHO, replacing 68
> line of mostly copy pasted code with 17 of a generic function is a bit
> more than "saving a few lines of code", so I think it's worth trying
> to find a solution that would be acceptable from both perspectives:
> conciseness and readability.

I think it's bad when grepping for a function name only reveals the
callers, maybe the declaraion, but not the definition of a function.
Using macros to define functions is sometimes very effective (and done
in barebox at other places), but not very nice to look at.

> 
> Would replacing function pointer with a switch (imx_cpu_type) and
> expanding IMX_BOOT_SAVE_LOC() make this patch readable enough to be
> accepted?

Not sure what exactly you mean, but the following should be fine. With
a bit of violating the coding style this is not longer than your solution,
but without hiding the function names behind a macro:

void vf610_boot_save_loc(void) { boot_save_loc(vf610_get_boot_source); }

Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2018-04-18  8:15 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-16 19:31 [PATCH v2 00/19] i.MX bootsource bugfixes, refactoring and VFxxx support Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 01/19] ARM: i.MX: boot: Coalesce copy-pasted code Andrey Smirnov
2018-04-17  6:58   ` Sascha Hauer
2018-04-17 15:20     ` Andrey Smirnov
2018-04-18  8:15       ` Sascha Hauer [this message]
2018-04-19 22:26         ` Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 02/19] include: Port linux/build_bug.h from Linux kernel Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 03/19] include: Port linux/bitfield.h " Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 04/19] ARM: i.MX: Add a function to extract BMOD value Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 05/19] ARM: i.MX: Simplify serial bootsource detection for i.MX6 and 7 Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 06/19] ARM: i.MX: Account for unprogrammed fuses on i.MX6 and i.MX7 Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 07/19] ARM: i.MX7: boot: Add code to handle SD/MMC manufacture mode Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 08/19] ARM: i.MX7: boot: Remove incorrect NAND bootsource detection Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 09/19] ARM: i.MX7: boot: Fix SPI-NOR/QSPI boot source mixup Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 10/19] ARM: i.MX: boot: Remove unnecessary returns Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 11/19] ARM: i.MX: boot: Move magic values into small functions Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 12/19] ARM: i.MX: boot: Share code to detect NAND as a boot source Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 13/19] ARM: i.MX: boot: Check for NAND boot only if necessary on i.MX53, 6 Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 14/19] ARM: i.MX53: boot: Move magic numbers info utility functions Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 15/19] ARM: i.MX6: boot: Move magic numbers into " Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 16/19] ARM: i.MX7: " Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 17/19] bootsource: Add BOOTSOURCE_CAN Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 18/19] ARM: VFxxx: Implement code to detect bootsource Andrey Smirnov
2018-04-16 19:31 ` [PATCH v2 19/19] ARM: i.MX6: boot: Return BOOTSOURCE_SPI_NOR, not BOOTSOURCE_SPI Andrey Smirnov
2018-04-17  7:24 ` [PATCH v2 00/19] i.MX bootsource bugfixes, refactoring and VFxxx support Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180418081515.fdusp7fvycmq7kij@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox