mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Antony Pavlov <antonynpavlov@gmail.com>
To: Oleksij Rempel <linux@rempel-privat.de>
Cc: barebox@lists.infradead.org
Subject: Re: [RFC PATCH 3/7] bootm: add kexec ELF support
Date: Fri, 4 May 2018 16:09:28 +0300	[thread overview]
Message-ID: <20180504160928.1bff26bf7e9853754be00d83@gmail.com> (raw)
In-Reply-To: <c55d956a-84e3-0a6c-0505-c5f0d722a9ae@rempel-privat.de>

On Fri, 4 May 2018 11:53:48 +0200
Oleksij Rempel <linux@rempel-privat.de> wrote:

> Am 04.05.2018 um 12:08 schrieb Antony Pavlov:
> > On Fri, 4 May 2018 07:54:08 +0200
> > Sascha Hauer <s.hauer@pengutronix.de> wrote:
> > 
> >> On Sun, Apr 29, 2018 at 03:09:03PM +0200, Oleksij Rempel wrote:
> >>> +static int do_bootm_elf(struct image_data *data)
> >>> +{
> >>> +	kexec_load_bootm_data(data);
> >>> +
> >>> +	reboot(LINUX_REBOOT_CMD_KEXEC, data);
> >>> +
> >>> +	return -ERESTARTSYS;
> >>> +}
> >>> +
> >>
> >> I can't really judge this series. This is the only thing I stumbled
> >> upon: I see no reason to name the architecture specific kexec function
> >> 'reboot'. I would expect some kexec specific name, like arch_kexec or
> >> similar.
> >>
> > 
> > This reboot function is copy-n-paste from linux kernel reboot syscall (see linux/kernel/reboot.c
> > for details).
> > At the moment there is only one constant for reboot()'s first argument (LINUX_REBOOT_CMD_KEXEC),
> > so it's reasonable to elimenate this first argument and rename function to kexec_reboot().
> 
> amy be better to rename it to kexec_arch or kexec_mach. kexec_reboot is
> kind if misleading

Linux uses machine_kexec(struct kimage *image) in arch/mips/kernel/machine_kexec.c.

-- 
Best regards,
  Antony Pavlov

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2018-05-04 12:53 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-29 13:09 [RFC PATCH 0/7] provide ELF/KEXEC support for MIPS ath79 and malta Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 1/7] resource: add create_resource() helper function Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 2/7] filetype: add ELF type Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 3/7] bootm: add kexec ELF support Oleksij Rempel
2018-05-04  5:54   ` Sascha Hauer
2018-05-04 10:08     ` Antony Pavlov
2018-05-04  9:53       ` Oleksij Rempel
2018-05-04 13:09         ` Antony Pavlov [this message]
2018-04-29 13:09 ` [RFC PATCH 4/7] MIPS: add kexec ELF loading support Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 5/7] MIPS: ath79: add kexec support Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 6/7] MIPS: malta: enable kexec Oleksij Rempel
2018-04-29 13:09 ` [RFC PATCH 7/7] MIPS: configs: add KEXEC=y to atheros devices Oleksij Rempel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180504160928.1bff26bf7e9853754be00d83@gmail.com \
    --to=antonynpavlov@gmail.com \
    --cc=barebox@lists.infradead.org \
    --cc=linux@rempel-privat.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox