mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 1/6] usb: hub: Use more accurate struct name
@ 2019-10-10  8:14 Jules Maselbas
  2019-10-10  8:14 ` [PATCH 2/6] usb: hub: Only clear port reset status if set Jules Maselbas
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Jules Maselbas @ 2019-10-10  8:14 UTC (permalink / raw)
  To: barebox; +Cc: Jules Maselbas

Both structures usb_hub_status and usb_port_status have the same
fields, only the name differ.

Signed-off-by: Jules Maselbas <jmaselbas@kalray.eu>
---
 drivers/usb/core/hub.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index d01a01607..91a938567 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -62,7 +62,7 @@ static int usb_get_port_status(struct usb_device *dev, int port, void *data)
 {
 	return usb_control_msg(dev, usb_rcvctrlpipe(dev, 0),
 			USB_REQ_GET_STATUS, USB_DIR_IN | USB_RT_PORT, 0, port,
-			data, sizeof(struct usb_hub_status), USB_CNTL_TIMEOUT);
+			data, sizeof(struct usb_port_status), USB_CNTL_TIMEOUT);
 }
 
 
-- 
2.21.0.196.g041f5ea


_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2019-10-14 15:10 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-10  8:14 [PATCH 1/6] usb: hub: Use more accurate struct name Jules Maselbas
2019-10-10  8:14 ` [PATCH 2/6] usb: hub: Only clear port reset status if set Jules Maselbas
2019-10-10  8:15 ` [PATCH 3/6] usb: string: Use dma_alloc instead of a local buffer Jules Maselbas
2019-10-10  8:15 ` [PATCH 4/6] usb: string: Use le16_to_cpu for langid Jules Maselbas
2019-10-10 20:41   ` Andrey Smirnov
2019-10-14 11:42   ` Sascha Hauer
2019-10-14 15:09     ` Jules Maselbas
2019-10-10  8:15 ` [PATCH 5/6] usb: string: size_t is unsigned Jules Maselbas
2019-10-10  8:15 ` [PATCH 6/6] usb: string: Minor changes Jules Maselbas

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox