mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 1/3] soc: kvx: Rename function to match global variable
@ 2023-07-11  9:11 Jules Maselbas
  2023-07-11  9:11 ` [PATCH 2/3] soc: kvx: Fix memory leaks Jules Maselbas
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Jules Maselbas @ 2023-07-11  9:11 UTC (permalink / raw)
  To: barebox; +Cc: Jules Maselbas

The global variable "kvx_serial" has been renamed to "kvx_mppa_id".
Do the same with the function name that sets this global variable.

Signed-off-by: Jules Maselbas <jmaselbas@kalray.eu>
---
 drivers/soc/kvx/kvx_socinfo.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/soc/kvx/kvx_socinfo.c b/drivers/soc/kvx/kvx_socinfo.c
index 8cac8899d2..fc7ba1c1b9 100644
--- a/drivers/soc/kvx/kvx_socinfo.c
+++ b/drivers/soc/kvx/kvx_socinfo.c
@@ -81,7 +81,7 @@ static int base38_decode(char *s, u64 val, int nb_char)
 	return 0;
 }
 
-static int kvx_read_serial(struct device_node *socinfo)
+static int kvx_read_mppa_id(struct device_node *socinfo)
 {
 	char lot_id[LOT_ID_STR_LEN + 1] = "";
 	char com_ap;
-- 
2.17.1








^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2023-07-26 19:02 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-07-11  9:11 [PATCH 1/3] soc: kvx: Rename function to match global variable Jules Maselbas
2023-07-11  9:11 ` [PATCH 2/3] soc: kvx: Fix memory leaks Jules Maselbas
2023-07-11  9:11 ` [PATCH 3/3] soc: kvx: Add board_sn global var from OTP Jules Maselbas
2023-07-26 12:26   ` Sascha Hauer
2023-07-26 19:00     ` Jules Maselbas
2023-07-26 12:18 ` [PATCH 1/3] soc: kvx: Rename function to match global variable Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox