mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: barebox@lists.infradead.org
Subject: [PATCH 00/12] include: common.h: make it include only headers
Date: Mon, 14 Oct 2024 13:50:28 +0200	[thread overview]
Message-ID: <20241014115040.2843121-1-a.fatoum@pengutronix.de> (raw)

Symbols exclusively defined in common.h are a problem, because other
headers that require them will need to include a lot of extra baggage,
which in the worst case can lead to cyclic dependencies and in every
case leads to longer compile times.

This series prepare for removing common.h in other headers by moving
everything it contains apart from #includes into more fitting existing
headers that are already being included.

Ahmad Fatoum (12):
  include: common.h: move barebox startup functions into separate header
  include: common.h: move ctrlc() functions into stdio.h
  include: common.h: move out integer string parsing functions
  include: common.h: move out endianness macro sanity check
  include: common.h: move out user interface functions into stdio.h
  include: common.h: move out memory option parsing prototypes
  include: common.h: move out RW_BUF_SIZE definition
  commands: add macro to simplify defining one shot commands
  commands: reginfo: make command mpc5xxx-specific
  include: common.h: move out get_ram_size
  include: align: reword STACK_ALIGN_ARRAY macro parameter for clarity
  ARM: bcm283x: remove common.h include in mbox.h

 arch/arm/boards/raspberry-pi/mbox-helpers.c |  1 +
 arch/powerpc/mach-mpc5xxx/Kconfig           |  4 -
 arch/powerpc/mach-mpc5xxx/Makefile          |  2 +-
 arch/powerpc/mach-mpc5xxx/reginfo.c         |  4 +-
 commands/Kconfig                            | 11 ---
 commands/Makefile                           |  1 -
 commands/reginfo.c                          | 21 ------
 include/barebox.h                           | 37 ++++++++++
 include/command.h                           | 15 ++++
 include/common.h                            | 81 +--------------------
 include/getopt.h                            |  8 ++
 include/linux/align.h                       | 11 +--
 include/linux/kstrtox.h                     |  6 ++
 include/mach/bcm283x/mbox.h                 |  4 +-
 include/stdio.h                             | 14 ++++
 include/unistd.h                            |  2 +
 lib/hexdump.c                               | 20 +++++
 17 files changed, 115 insertions(+), 127 deletions(-)
 delete mode 100644 commands/reginfo.c
 create mode 100644 include/barebox.h

-- 
2.39.5




             reply	other threads:[~2024-10-14 13:30 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-14 11:50 Ahmad Fatoum [this message]
2024-10-14 11:50 ` [PATCH 01/12] include: common.h: move barebox startup functions into separate header Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 02/12] include: common.h: move ctrlc() functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 03/12] include: common.h: move out integer string parsing functions Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 04/12] include: common.h: move out endianness macro sanity check Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 05/12] include: common.h: move out user interface functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 06/12] include: common.h: move out memory option parsing prototypes Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 07/12] include: common.h: move out RW_BUF_SIZE definition Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 08/12] commands: add macro to simplify defining one shot commands Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 09/12] commands: reginfo: make command mpc5xxx-specific Ahmad Fatoum
2024-10-15  7:13   ` Sascha Hauer
2024-10-15  7:20     ` Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 10/12] include: common.h: move out get_ram_size Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 11/12] include: align: reword STACK_ALIGN_ARRAY macro parameter for clarity Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 12/12] ARM: bcm283x: remove common.h include in mbox.h Ahmad Fatoum
2024-10-15  7:10 ` [PATCH 00/12] include: common.h: make it include only headers Sascha Hauer
2024-10-15  7:16   ` Sascha Hauer
2024-10-15 13:35     ` Konstantin Ryabitsev
2024-10-16 10:25       ` Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241014115040.2843121-1-a.fatoum@pengutronix.de \
    --to=a.fatoum@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox