mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 00/12] include: common.h: make it include only headers
@ 2024-10-14 11:50 Ahmad Fatoum
  2024-10-14 11:50 ` [PATCH 01/12] include: common.h: move barebox startup functions into separate header Ahmad Fatoum
                   ` (12 more replies)
  0 siblings, 13 replies; 19+ messages in thread
From: Ahmad Fatoum @ 2024-10-14 11:50 UTC (permalink / raw)
  To: barebox

Symbols exclusively defined in common.h are a problem, because other
headers that require them will need to include a lot of extra baggage,
which in the worst case can lead to cyclic dependencies and in every
case leads to longer compile times.

This series prepare for removing common.h in other headers by moving
everything it contains apart from #includes into more fitting existing
headers that are already being included.

Ahmad Fatoum (12):
  include: common.h: move barebox startup functions into separate header
  include: common.h: move ctrlc() functions into stdio.h
  include: common.h: move out integer string parsing functions
  include: common.h: move out endianness macro sanity check
  include: common.h: move out user interface functions into stdio.h
  include: common.h: move out memory option parsing prototypes
  include: common.h: move out RW_BUF_SIZE definition
  commands: add macro to simplify defining one shot commands
  commands: reginfo: make command mpc5xxx-specific
  include: common.h: move out get_ram_size
  include: align: reword STACK_ALIGN_ARRAY macro parameter for clarity
  ARM: bcm283x: remove common.h include in mbox.h

 arch/arm/boards/raspberry-pi/mbox-helpers.c |  1 +
 arch/powerpc/mach-mpc5xxx/Kconfig           |  4 -
 arch/powerpc/mach-mpc5xxx/Makefile          |  2 +-
 arch/powerpc/mach-mpc5xxx/reginfo.c         |  4 +-
 commands/Kconfig                            | 11 ---
 commands/Makefile                           |  1 -
 commands/reginfo.c                          | 21 ------
 include/barebox.h                           | 37 ++++++++++
 include/command.h                           | 15 ++++
 include/common.h                            | 81 +--------------------
 include/getopt.h                            |  8 ++
 include/linux/align.h                       | 11 +--
 include/linux/kstrtox.h                     |  6 ++
 include/mach/bcm283x/mbox.h                 |  4 +-
 include/stdio.h                             | 14 ++++
 include/unistd.h                            |  2 +
 lib/hexdump.c                               | 20 +++++
 17 files changed, 115 insertions(+), 127 deletions(-)
 delete mode 100644 commands/reginfo.c
 create mode 100644 include/barebox.h

-- 
2.39.5




^ permalink raw reply	[flat|nested] 19+ messages in thread

end of thread, other threads:[~2024-10-16 10:27 UTC | newest]

Thread overview: 19+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-10-14 11:50 [PATCH 00/12] include: common.h: make it include only headers Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 01/12] include: common.h: move barebox startup functions into separate header Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 02/12] include: common.h: move ctrlc() functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 03/12] include: common.h: move out integer string parsing functions Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 04/12] include: common.h: move out endianness macro sanity check Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 05/12] include: common.h: move out user interface functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 06/12] include: common.h: move out memory option parsing prototypes Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 07/12] include: common.h: move out RW_BUF_SIZE definition Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 08/12] commands: add macro to simplify defining one shot commands Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 09/12] commands: reginfo: make command mpc5xxx-specific Ahmad Fatoum
2024-10-15  7:13   ` Sascha Hauer
2024-10-15  7:20     ` Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 10/12] include: common.h: move out get_ram_size Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 11/12] include: align: reword STACK_ALIGN_ARRAY macro parameter for clarity Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 12/12] ARM: bcm283x: remove common.h include in mbox.h Ahmad Fatoum
2024-10-15  7:10 ` [PATCH 00/12] include: common.h: make it include only headers Sascha Hauer
2024-10-15  7:16   ` Sascha Hauer
2024-10-15 13:35     ` Konstantin Ryabitsev
2024-10-16 10:25       ` Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox