mail archive of the barebox mailing list
 help / color / mirror / Atom feed
[PATCH 1/2] fbconsole: support fonts wider than 16 pixels
 2024-08-24 20:04 UTC  (2+ messages)
` [PATCH 2/2] fonts: add TER16x32 font

[PATCH] doc: bcm283x: Mention arm_64bit config.txt key
 2024-08-24 20:03 UTC 

[PATCH master] input: don't report depressed keys that were never pressed
 2024-08-24 20:02 UTC 

[PATCH] include: move STACK_ALIGN_ARRAY to linux/align.h
 2024-08-24 20:02 UTC 

[PATCH] lib: math: rename file providing arith() to arith.c
 2024-08-24 20:01 UTC 

[PATCH] ci: container: restore OpenRISC toolchain to v14.2.0
 2024-08-23  9:23 UTC 

[PATCH master] ARM: semihosting: use svc instead of incorrect bkpt in DEBUG_LL
 2024-08-23  8:05 UTC  (2+ messages)

[PATCH 1/3] MIPS: dts: add /chosen/stdout-path where it is missing
 2024-08-23  8:05 UTC  (4+ messages)
` [PATCH 2/3] MIPS: qemu-malta: explicitly set stdout-path
` [PATCH 3/3] test: mips: use new qemu-maltael_defconfig

[PATCH] ARM: socfpga: drop unused Arria 10 barebox-arm-head.h
 2024-08-23  8:04 UTC  (2+ messages)

[PATCH] test: directly exit when barebox state transition fails
 2024-08-23  8:04 UTC  (2+ messages)

[PATCH 1/5] test: conftest.py: move top-level
 2024-08-23  8:04 UTC  (6+ messages)
` [PATCH 2/5] MAKEALL: return error code from do_build_target
` [PATCH 3/5] MAKEALL: don't build all configs wen defconfigs given
` [PATCH 4/5] MAKEALL: add support for running pytest after build
` [PATCH 5/5] Documentation: board: emulated: rewrite to use MAKEALL/pytest directly

[PATCH master] openrisc: dts: describe all 4 UARTs
 2024-08-23  7:57 UTC  (2+ messages)

[PATCH 1/3] debug_ll: ns16550: fix prototype in documentation comment
 2024-08-23  6:21 UTC  (9+ messages)
` [PATCH 2/3] openrisc: implement C debug_ll for NS16550
` [PATCH 3/3] ci: container: downgrade OpenRISC toolchain from 14.2.0 to 13.1.0
  ` (subset) "
` (subset) [PATCH 1/3] debug_ll: ns16550: fix prototype in documentation comment

[PATCH master] ci: container: fix CROSS_COMPILE_openrisc to point at correct version
 2024-08-22 12:04 UTC  (2+ messages)

[PATCH v2] acpi: fix compilation for 32-bit
 2024-08-22 10:52 UTC  (4+ messages)

[PATCH v3] acpi: fix compilation for 32-bit
 2024-08-22 10:52 UTC  (2+ messages)

[PATCH] ci: container: rerun workflow when modifying container.yml
 2024-08-20 13:06 UTC 

[PATCH 1/2] include: linux/math.h: promote DIV_ROUND_UP_ULL args to 64-bit
 2024-08-20 12:07 UTC  (4+ messages)
` [PATCH 2/2] i2c: efi: use DIV_ROUND_UP_ULL instead of native division

[PATCH 1/6] common: pe: fix use of undefined macro for ARMv7
 2024-08-19  6:16 UTC  (10+ messages)
` [PATCH 2/6] efi: fs: fix determination of read-only files
` [PATCH 3/6] filetype: fix else clause indentation
` [PATCH 4/6] acpi: fix compilation for 32-bit
` [PATCH 5/6] i2c: efi: avoid 64-bit division
` [PATCH 6/6] net: fsl_enetc: fix compilation for 32-bit

[PATCH 00/11] gpiolib: add support for OF GPIO configuration binding
 2024-08-14 11:00 UTC  (13+ messages)
` [PATCH 01/11] gpio: make gpio.h header self-contained
` [PATCH 02/11] gpiolib: permit GPIO drivers to implement struct gpio_ops::set_config
` [PATCH 03/11] pinctrl: stm32: implement generic "
` [PATCH 04/11] gpiolib: turn request/active_low into bit flags
` [PATCH 05/11] gpiolib: don't use GPIO number API in of_hog_gpio
` [PATCH 06/11] gpiolib: store all OF flags into GPIO descriptor
` [PATCH 07/11] gpiolib: add support for OF GPIO configuration binding
` [PATCH 08/11] gpiolib: use dev_gpiod_get_index device node argument throughout
` [PATCH 09/11] gpiolib: export function to get struct gpio_desc from index
` [PATCH 10/11] input: gpio_keys: switch to GPIO descriptor API
` [PATCH 11/11] input: gpio-keys: request with label in DT if available

[PATCH] ci: container: make wget less verbose
 2024-08-14 10:41 UTC  (2+ messages)

[PATCH] ARM: i.MX: drop explicit reservation of scratch area
 2024-08-14 10:39 UTC  (2+ messages)

[PATCH v2 1/3] kvx: add qemu dts
 2024-08-14 10:38 UTC  (5+ messages)
` [PATCH v2 2/3] ci: container: add qemu-system-kvx
` [PATCH v2 3/3] ci: add support for running basic tests on kvx arch

[PATCH 1/4] ARM: add ARM32/ARM64 symbols for use in generic code
 2024-08-14  9:14 UTC  (6+ messages)
` [PATCH 2/4] efi: payload: force PBL_FULLY_PIC for ARM64
` [PATCH 3/4] efi: payload: alert user if CONFIG_FS_EFI is missing
` [PATCH 4/4] ARM: i.MX8M: neuter initcalls when EFI booted
` (subset) [PATCH 1/4] ARM: add ARM32/ARM64 symbols for use in generic code

[PATCH 1/3] fastboot: print all variables only on getvar:all and not its prefixes
 2024-08-14  8:53 UTC  (4+ messages)
` [PATCH 2/3] fastboot: retire strcmp_l1 in favor of str_has_prefix
` [PATCH 3/3] fastboot: avoid console_countdown_abort for getvar request

[PATCH] clk: imx: clk-pllv2: Fix unitialized variable warning
 2024-08-14  8:46 UTC  (2+ messages)

[PATCH] fixup! ci: pytest: test sandbox configuration with labgrid
 2024-08-14  8:33 UTC 

[PATCH] common: make BOOTM_SHOW_TYPE depend on UIMAGE
 2024-08-14  8:26 UTC  (2+ messages)

[PATCH 1/3] Documentation: devel: background-execution: update section on I2C slices
 2024-08-14  8:06 UTC  (5+ messages)
` [PATCH 2/3] Documentation: user: intro: add more info about mailing list
` [PATCH 3/3] README: bring it up to date

[PATCH 1/7] ci: container: update to Debian Bookworm with GCC v14.2.0
 2024-08-14  7:49 UTC  (8+ messages)
` [PATCH 2/7] ci: container: add kvx-elf- toolchain
` [PATCH 3/7] ci: container: update to newest Labgrid release
` [PATCH 4/7] test: sandbox: support testing with Labgrid
` [PATCH 5/7] ci: pytest: test sandbox configuration with labgrid
` [PATCH 6/7] ci: build: add kvx build test
` [PATCH 7/7] test: py: strategy: drop no longer needed labgrid workarounds

[PATCH] ARM: i.MX8MP: König+Bauer AlphaJet: remove barebox partition from eMMC
 2024-08-14  7:42 UTC  (2+ messages)

[PATCH 1/3] kvx: add qemu dts
 2024-08-13  6:36 UTC  (7+ messages)
` [PATCH 2/3] ci: container: add qemu-system-kvx
` [PATCH 3/3] ci: add support for running basic tests on kvx arch

AW: Re: barebox on EFI bios and secure boot
 2024-08-12 15:26 UTC 

[PATCH 1/6] ci: container: update to Debian Bookworm with GCC v14.2.0
 2024-08-12 13:30 UTC  (9+ messages)
` [PATCH 2/6] ci: container: add kvx-elf- toolchain
` [PATCH 3/6] ci: container: update to newer Labgrid
` [PATCH 4/6] test: sandbox: support testing with Labgrid
` [PATCH 5/6] ci: pytest: test sandbox configuration with labgrid
` [PATCH 6/6] ci: build: add kvx build test

barebox on EFI bios and secure boot
 2024-08-12 12:09 UTC  (2+ messages)

[PATCH 1/2] malloc: implement malloc_usable_size()
 2024-08-07  6:58 UTC  (5+ messages)
` [PATCH 2/2] malloc: implement free_sensitive()
` [PATCH] fixup! malloc: implement malloc_usable_size()
  ` (subset) "

short entropy delay causes RNG hardware error
 2024-08-06 17:00 UTC  (4+ messages)

v2024.08.0
 2024-08-06 10:44 UTC 

[PATCH v2 00/19] Add ECDSA support for FIT image verification
 2024-08-06  9:13 UTC  (45+ messages)
` [PATCH v2 01/19] errno: include string for EOPNOTSUPP
` [PATCH v2 02/19] rsatoc: disable deprecated function warnings
` [PATCH v2 03/19] rsatoc: remove unnecessary function call
` [PATCH v2 04/19] rsatoc: pass EVP_PKEY around
` [PATCH v2 05/19] rsatoc: rename rsa_err() to openssl_error()
` [PATCH v2 06/19] rsatoc: move engine initialization to engine_get_pub_key()
` [PATCH v2 07/19] rsatoc: cleanup error handling
` [PATCH v2 08/19] rsatoc: remove unnecessary error check
` [PATCH v2 09/19] rsatoc: use non deprecated openssl functions to retrieve RSA params
` [PATCH v2 10/19] rsatoc: check error value of gen_key()
` [PATCH v2 11/19] rsatoc: rename to keytoc
` [PATCH v2 12/19] keytoc: add ecdsa support
` [PATCH v2 13/19] keytoc: Let openssl_error() take a format string
` [PATCH v2 14/19] keytoc: clarify error messages
` [PATCH v2 15/19] malloc: implement free_sensitive()
` [PATCH v2 16/19] Add elliptic curve cryptography (ECC) helper functions
` [PATCH v2 17/19] crypto: add ECDSA support
` [PATCH v2 18/19] crypto: make RSA a visible option
` [PATCH v2 19/19] fit: Add ecdsa support

[PATCH] console: countdown: report who is interrupting
 2024-08-06  8:24 UTC  (2+ messages)

eth frame error on imx6ul
 2024-08-06  7:59 UTC  (5+ messages)

[PATCH 0/9] Add ECDSA support for FIT image verification
 2024-08-06  6:03 UTC  (2+ messages)

[PATCH] bootchooser: warn if NV is used instead of barebox-state
 2024-08-06  5:57 UTC  (2+ messages)

[PATCH master] usb: xhci: fix erroneous USB_DT_CONFIG descriptor size
 2024-08-06  5:56 UTC  (2+ messages)

[PATCH] ARM: rockchip: dmc: reduce number of leading zeroes
 2024-08-06  5:55 UTC  (2+ messages)

[PATCH master] optee: include linux/limits.h to define U64_MAX
 2024-08-06  5:54 UTC  (2+ messages)

[PATCH] fixup! console: add new CONSOLE_ACTIVATE_ALL_FALLBACK option
 2024-08-06  5:54 UTC  (2+ messages)

bootchooser: avoid write environment
 2024-08-05 13:36 UTC  (3+ messages)

[PATCH] parameter: fix parameter name to reflect usage
 2024-08-05 12:54 UTC  (2+ messages)

[PATCH 1/2] Fix Kconfig coding style from spaces to tab
 2024-08-02  5:49 UTC  (3+ messages)
` [PATCH 2/2] Fix Makefile "

[PATCH] fixup! debug_ll: implement putws_ll
 2024-08-01 12:51 UTC  (2+ messages)

[PATCH] console: honour OF current-speed property if available
 2024-08-01 11:36 UTC  (2+ messages)

[PATCH 1/5] console: provide veprintf and eputchar helpers
 2024-08-01 11:33 UTC  (2+ messages)

[PATCH] debug_ll: implement putws_ll
 2024-08-01 11:31 UTC  (2+ messages)

[PATCH] efi: define extra efi_memory_type flags
 2024-08-01 11:30 UTC  (2+ messages)

[PATCH v2 00/10] mmc: add SD/eMMC erase support
 2024-08-01 11:27 UTC  (7+ messages)
` [PATCH v2 01/10] fs: give erase() a new erase_type parameter
` [PATCH v2 08/10] mci: add support for discarding write blocks

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox