mail archive of the barebox mailing list
 help / color / mirror / Atom feed
[PATCH 0/3] spi-gpio updates
 2024-09-26  7:16 UTC  (9+ messages)
` [PATCH 1/3] spi: spi-gpio: actually delay in spidelay()
` [PATCH 2/3] spi: spi-gpio: support different word widths
` [PATCH 3/3] spi: spi-gpio: switch to new gpio binding

[PATCH 0/5] graphics updates
 2024-09-26  7:02 UTC  (13+ messages)
` [PATCH 1/5] graphic_utils: Clip to screen boundaries
` [PATCH 2/5] commands: splash: honour line_length
` [PATCH 3/5] gui: fix alpha blend
` [PATCH 4/5] fbconsole: make background pixels transparent
` [PATCH 5/5] fbconsole: actually store rows/cols

[PATCH 00/10] ARM: add assembler optimized memmove
 2024-09-26  5:51 UTC  (21+ messages)
` [PATCH 01/10] ARM: Use optimized reads[bwl] and writes[bwl] functions
` [PATCH 02/10] ARM: rename logical shift macros push pull into lspush lspull
` [PATCH 03/10] ARM: convert all "mov.* pc, reg" to "bx reg" for ARMv6+
` [PATCH 04/10] ARM: update lib1funcs.S from Linux
` [PATCH 05/10] ARM: update findbit.S "
` [PATCH 06/10] ARM: update io-* "
` [PATCH 07/10] ARM: always assume the unified syntax for assembly code
` [PATCH 08/10] ARM: update memcpy.S and memset.S from Linux
` [PATCH 09/10] lib/string.c: export non optimized memmove as __default_memmove
` [PATCH 10/10] ARM: add optimized memmove

[PATCH 0/5] of-graph fixes
 2024-09-25 14:01 UTC  (6+ messages)
` [PATCH 1/5] of: fix of_get_next_child() for prev->parent != node
` [PATCH 2/5] of: fix of_graph_get_next_endpoint()
` [PATCH 3/5] of: of_graph: honour ports subnode
` [PATCH 4/5] of: of_graph: fix of_graph_get_next_endpoint()
` [PATCH 5/5] of: of_graph: add missing functions

[PATCH v4 00/16] Add ECDSA support for FIT image verification
 2024-09-25  8:53 UTC  (20+ messages)
` [PATCH v4 01/16] keytoc: remove ECDSA dts support
` [PATCH v4 02/16] keytoc: fail in case gen_key() fails
` [PATCH v4 03/16] keytoc: fix ECDSA endianess problems
` [PATCH v4 04/16] keytoc: remove duplicate __ENV__ check
` [PATCH v4 05/16] crypto: Makefile: make simpler
` [PATCH v4 06/16] crypto/Makefile: Drop unnecessary dependencies
` [PATCH v4 07/16] keytoc: make key name hint optional
` [PATCH v4 08/16] crypto: rsa: include key name hint into CONFIG_CRYPTO_RSA_KEY
` [PATCH v4 09/16] crypto: rsa: encapsulate rsa keys in public keys struct
` [PATCH v4 10/16] crypto: add public_key functions
` [PATCH v4 11/16] crypto: builtin_keys: Allow to specify multiple keys in CONFIG_CRYPTO_PUBLIC_KEYS
` [PATCH v4 12/16] crypto: public-keys: use array of public_keys
` [PATCH v4 13/16] crypto: rsa: create static inline wrapper for rsa_verify()
` [PATCH v4 14/16] Add elliptic curve cryptography (ECC) helper functions
` [PATCH v4 15/16] crypto: add ECDSA support
` [PATCH v4 16/16] crypto: make RSA a visible option

[PATCH] efi: payload: image use new CONFIG_ARM64 symbol
 2024-09-20  9:49 UTC 

[PATCH] arm: rockchip: add support for the xulong orangepi 5 plus
 2024-09-19  6:47 UTC  (2+ messages)

[PATCH] wd_core: remove obsolete watchdog list
 2024-09-19  6:45 UTC  (2+ messages)

[PATCH] common: add custom autoboot_abort_key
 2024-09-16 13:53 UTC 

v2024.09.0
 2024-09-13  8:34 UTC 

[PATCH v3 00/15] Add ECDSA support for FIT image verification
 2024-09-13  7:06 UTC  (23+ messages)
` [PATCH v3 01/15] keytoc: remove ECDSA dts support
` [PATCH v3 02/15] keytoc: fail in case gen_key() fails
` [PATCH v3 03/15] keytoc: fix ECDSA endianess problems
` [PATCH v3 04/15] keytoc: remove duplicate __ENV__ check
` [PATCH v3 05/15] crypto: Makefile: make simpler
` [PATCH v3 06/15] keytoc: make key name hint optional
` [PATCH v3 07/15] crypto: rsa: include key name hint into CONFIG_CRYPTO_RSA_KEY
` [PATCH v3 08/15] crypto: rsa: encapsulate rsa keys in public keys struct
` [PATCH v3 09/15] crypto: add public_key functions
` [PATCH v3 10/15] crypto: builtin_keys: Allow to specify multiple keys in CONFIG_CRYPTO_PUBLIC_KEYS
` [PATCH v3 11/15] crypto: public-keys: use array of public_keys
` [PATCH v3 12/15] crypto: rsa: create static inline wrapper for rsa_verify()
` [PATCH v3 13/15] Add elliptic curve cryptography (ECC) helper functions
` [PATCH v3 14/15] crypto: add ECDSA support
` [PATCH v3 15/15] crypto: make RSA a visible option

[PATCH master 1/2] lib: jsmn: fix compilation error
 2024-09-13  6:32 UTC  (3+ messages)
` [PATCH master 2/2] include: stdlib.h: define prototypes for malloc/free

[PATCH] MIPS: fix elf_check_arch(x)
 2024-09-11  8:40 UTC  (2+ messages)

[PATCH 1/2] lib: drop separate int_sqrt.h header
 2024-09-11  8:40 UTC  (3+ messages)
` [PATCH 2/2] include: linux/math.h: sync with linux

[PATCH] lib: notifier: allow unregistering notifier in notifier_call_chain
 2024-09-11  8:38 UTC  (2+ messages)

[PATCH v2] sandbox: lds: fix "ELF has a LOAD segment with RWX permissions" warning
 2024-09-11  8:37 UTC  (2+ messages)

[PATCH] ARM: errata: document errata workarounds
 2024-09-11  8:36 UTC  (2+ messages)

[PATCH] font: fbconsole: use DIV_ROUND_UP for clarity
 2024-09-11  8:30 UTC  (2+ messages)

[PATCH] PWM: core: make pwm.h header self-contained
 2024-09-11  8:30 UTC  (2+ messages)

[PATCH] ARM: psci: hide ARM_PSCI options when ARCH_IMX7 is disabled
 2024-09-11  8:30 UTC  (2+ messages)

[PATCH 1/3] ARM: rpi: turn fixup message into debug messages
 2024-09-11  8:29 UTC  (4+ messages)
` [PATCH 2/3] ARM: rpi: always add built-in env
` [PATCH 3/3] ARM: rpi: return correct error code when failing to read revision

Bufferoverflow on eMMC partition handling
 2024-09-11  8:28 UTC  (5+ messages)

[PATCH master] Kbuild: update gen_compile_commands.py
 2024-09-11  8:28 UTC  (2+ messages)

[PATCH 0/4] dma: debug: track DMA buffer ownership with KASAN
 2024-09-10 11:48 UTC  (5+ messages)
` [PATCH 1/4] Revert "dma: debug: detect repeated DMA sync"
` [PATCH 2/4] KASan: implement non-warning kasan_is_poisoned_shadow
` [PATCH 3/4] dma: debug: poison DMA buffers with KASAN while owned by device
` [PATCH 4/4] dma: debug: detect repeated DMA sync using KASAN

[PATCH] include: linux/iopoll: fix uninitialized warning
 2024-09-10  8:25 UTC  (3+ messages)

[PATCH] mci: avoid out of bounds partition access
 2024-09-05 13:19 UTC  (2+ messages)

Bufferoverflow on eMMC partition handling
 2024-09-02  9:36 UTC 

[PATCH] clk: rockchip: clk-rk3588: Fix 32k clock name for pmu_24m_32k_100m_src_p
 2024-09-02  7:59 UTC  (2+ messages)

[PATCH] partitions: dos: prefix hex sector numbers with 0x
 2024-09-02  7:59 UTC  (2+ messages)

[PATCH 1/2] fbconsole: support fonts wider than 16 pixels
 2024-08-26 11:13 UTC  (3+ messages)
` [PATCH 2/2] fonts: add TER16x32 font

[PATCH] doc: bcm283x: Mention arm_64bit config.txt key
 2024-08-26 11:08 UTC  (2+ messages)

[PATCH master] input: don't report depressed keys that were never pressed
 2024-08-26 11:08 UTC  (2+ messages)

[PATCH] include: move STACK_ALIGN_ARRAY to linux/align.h
 2024-08-26 11:07 UTC  (2+ messages)

[PATCH] ARM: socfpga: drop unused Arria 10 barebox-arm-head.h
 2024-08-26 11:06 UTC  (3+ messages)

[PATCH] lib: math: rename file providing arith() to arith.c
 2024-08-26 11:06 UTC  (2+ messages)

[PATCH] ci: container: restore OpenRISC toolchain to v14.2.0
 2024-08-23  9:23 UTC 

[PATCH master] ARM: semihosting: use svc instead of incorrect bkpt in DEBUG_LL
 2024-08-23  8:05 UTC  (2+ messages)

[PATCH 1/3] MIPS: dts: add /chosen/stdout-path where it is missing
 2024-08-23  8:05 UTC  (4+ messages)
` [PATCH 2/3] MIPS: qemu-malta: explicitly set stdout-path
` [PATCH 3/3] test: mips: use new qemu-maltael_defconfig

[PATCH] test: directly exit when barebox state transition fails
 2024-08-23  8:04 UTC  (2+ messages)

[PATCH 1/5] test: conftest.py: move top-level
 2024-08-23  8:04 UTC  (6+ messages)
` [PATCH 2/5] MAKEALL: return error code from do_build_target
` [PATCH 3/5] MAKEALL: don't build all configs wen defconfigs given
` [PATCH 4/5] MAKEALL: add support for running pytest after build
` [PATCH 5/5] Documentation: board: emulated: rewrite to use MAKEALL/pytest directly

[PATCH master] openrisc: dts: describe all 4 UARTs
 2024-08-23  7:57 UTC  (2+ messages)

[PATCH 1/3] debug_ll: ns16550: fix prototype in documentation comment
 2024-08-23  6:21 UTC  (8+ messages)
` [PATCH 3/3] ci: container: downgrade OpenRISC toolchain from 14.2.0 to 13.1.0
  ` (subset) "
` (subset) [PATCH 1/3] debug_ll: ns16550: fix prototype in documentation comment

[PATCH master] ci: container: fix CROSS_COMPILE_openrisc to point at correct version
 2024-08-22 12:04 UTC  (2+ messages)

[PATCH v2] acpi: fix compilation for 32-bit
 2024-08-22 10:52 UTC  (4+ messages)

[PATCH v3] acpi: fix compilation for 32-bit
 2024-08-22 10:52 UTC  (2+ messages)

[PATCH] ci: container: rerun workflow when modifying container.yml
 2024-08-20 13:06 UTC 

[PATCH 1/2] include: linux/math.h: promote DIV_ROUND_UP_ULL args to 64-bit
 2024-08-20 12:07 UTC  (4+ messages)
` [PATCH 2/2] i2c: efi: use DIV_ROUND_UP_ULL instead of native division

[PATCH 1/6] common: pe: fix use of undefined macro for ARMv7
 2024-08-19  6:16 UTC  (5+ messages)
` [PATCH 5/6] i2c: efi: avoid 64-bit division

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox