mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sascha Hauer <sha@pengutronix.de>
To: Ahmad Fatoum <a.fatoum@pengutronix.de>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node
Date: Tue, 10 Jan 2023 15:44:02 +0100	[thread overview]
Message-ID: <20230110144402.GL28911@pengutronix.de> (raw)
In-Reply-To: <20230109110921.1590312-1-a.fatoum@pengutronix.de>

On Mon, Jan 09, 2023 at 12:09:19PM +0100, Ahmad Fatoum wrote:
>   - Out-of-tree patches often add a board driver, which may use the
>     old device_d/driver_d naming. Especially with bisecting, this can
>     be a hassle
> 
>   - We may split up some parts of struct device into a new
>     struct platform_device like Linux does and we don't want
>     to break out of tree patches twice.
> 
> Thus add the old names as aliases for now.
> 
> Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
> ---
>  include/driver.h | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)

Applied, thanks

Sascha

> 
> diff --git a/include/driver.h b/include/driver.h
> index 693d5cb3e580..c789f3151e70 100644
> --- a/include/driver.h
> +++ b/include/driver.h
> @@ -74,7 +74,10 @@ struct device {
>  	struct list_head cdevs;
>  
>  	const struct platform_device_id *id_entry;
> -	struct device_node *of_node;
> +	union {
> +		struct device_node *device_node;
> +		struct device_node *of_node;
> +	};
>  
>  	const struct of_device_id *of_id_entry;
>  
> -- 
> 2.30.2
> 
> 
> 

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |



      parent reply	other threads:[~2023-01-10 14:45 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-09 11:09 Ahmad Fatoum
2023-01-09 11:09 ` [PATCH 2/3] fixup! Rename struct device_d to device Ahmad Fatoum
2023-01-09 11:09 ` [PATCH 3/3] fixup! Rename struct driver_d to driver Ahmad Fatoum
2023-01-10 14:44 ` Sascha Hauer [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230110144402.GL28911@pengutronix.de \
    --to=sha@pengutronix.de \
    --cc=a.fatoum@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox