mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: barebox@lists.infradead.org
Cc: Ahmad Fatoum <a.fatoum@pengutronix.de>
Subject: [PATCH 3/3] fixup! Rename struct driver_d to driver
Date: Mon,  9 Jan 2023 12:09:21 +0100	[thread overview]
Message-ID: <20230109110921.1590312-3-a.fatoum@pengutronix.de> (raw)
In-Reply-To: <20230109110921.1590312-1-a.fatoum@pengutronix.de>

  - Out-of-tree patches often add a board driver, which may use the
    old device_d/driver_d naming. Especially with bisecting, this can
    be a hassle

  - We may split up some parts of struct device into a new
    struct platform_device like Linux does and we don't want
    to break out of tree patches twice.

Thus add the old names as aliases for now.

Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
---
 include/driver.h | 1 +
 1 file changed, 1 insertion(+)

diff --git a/include/driver.h b/include/driver.h
index dfe1878163ac..2a12952215de 100644
--- a/include/driver.h
+++ b/include/driver.h
@@ -123,6 +123,7 @@ struct driver {
 
 /* Legacy naming for out-of-tree patches. Will be phased out in future. */
 #define device_d device
+#define driver_d driver
 
 #define RW_SIZE(x)      (x)
 #define RW_SIZE_MASK    0x7
-- 
2.30.2




  parent reply	other threads:[~2023-01-09 11:11 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-09 11:09 [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node Ahmad Fatoum
2023-01-09 11:09 ` [PATCH 2/3] fixup! Rename struct device_d to device Ahmad Fatoum
2023-01-09 11:09 ` Ahmad Fatoum [this message]
2023-01-10 14:44 ` [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230109110921.1590312-3-a.fatoum@pengutronix.de \
    --to=a.fatoum@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox