mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: "Sascha Hauer" <s.hauer@pengutronix.de>
To: "Luca Lauro via B4 Relay" <devnull+famlauro93l.gmail.com@kernel.org>
Cc: "open list:BAREBOX" <barebox@lists.infradead.org>,
	"Luca Lauro" <famlauro93l@gmail.com>
Subject: Re: [PATCH v4 04/14] ARM: mvebu: rename PUTC_LL to MVEBU_PUTC_LL
Date: Fri, 21 Aug 2026 10:38:37 +0000	[thread overview]
Message-ID: <2e8bdbc7-5a4f-4dcf-8703-a0683424d418@pengutronix.de> (raw)
In-Reply-To: <20260813-rn102-rn104-series-v4-4-f932ac63efa0@gmail.com>

On 2026-08-13 17:26, Luca Lauro via B4 Relay wrote:
> From: Luca Lauro <famlauro93l@gmail.com>
> 
> The name PUTC_LL is used by multiple architectures in barebox for their
> early low-level UART output helpers. Since these functions differ between
> SoCs and are defined in architecture-specific debug_ll headers, using the
> same global name can lead to collisions or accidental overrides when
> including multiple debug_ll headers.
> 
> To avoid such namespace conflicts and to make the origin of the function
> explicit, rename the mvebu-specific PUTC_LL to MVEBU_PUTC_LL.

This patch is wrong. The idea of PUTC_LL is that the implementations are
all included exclusively. See arch/arm/include/asm/debug_ll.h which
includes exactly one SoC header file. You shouldn't include
mach/mvebu/debug_ll.h directly, but instead only indirectly via
include/debug_ll.h.

Did you see any specific link failures/duplicate definitions that
motivated you to this patch?

Sascha

>
> Signed-off-by: Luca Lauro <famlauro93l@gmail.com>
> ---
>  include/mach/mvebu/debug_ll.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/mach/mvebu/debug_ll.h b/include/mach/mvebu/debug_ll.h
> index cf08776d4f..cd81b27e39 100644
> --- a/include/mach/mvebu/debug_ll.h
> +++ b/include/mach/mvebu/debug_ll.h
> @@ -15,7 +15,7 @@
>  
>  #define EARLY_UART	UARTn_BASE(CONFIG_MVEBU_CONSOLE_UART)
>  
> -static inline void PUTC_LL(char c)
> +static inline void MVEBU_PUTC_LL(char c)
>  {
>  	/* Wait until there is space in the FIFO */
>  	while (!(readl(EARLY_UART + UART_LSR) & LSR_THRE))
> 
> -- 
> 2.47.3
> 
> 

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |




  reply	other threads:[~2026-08-21 10:40 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-13 15:26 [PATCH v4 00/14] (no cover subject) Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 01/14] ARM: mvebu: add Netgear RN102 support Luca Lauro via B4 Relay
2026-08-17  7:51   ` Sascha Hauer
2026-08-18  8:44     ` Uwe Kleine-König
2026-08-19  7:16       ` Sascha Hauer
2026-08-19  7:39         ` Uwe Kleine-König
     [not found]       ` <6a85585d.5770c427.2e0747.7f3dSMTPIN_ADDED_MISSING@mx.google.com>
2026-08-20 17:59         ` Luca Lauro
2026-08-21 10:07           ` Sascha Hauer
2026-08-21 11:57             ` Luca Lauro
2026-08-20 14:35     ` Luca Lauro
     [not found]     ` <CANRe2W+Cp82qe+R_VNf_hXV+NRet+F63fq34pEw3FR-s4kw3zg@mail.gmail.com>
2026-08-21  9:17       ` Sascha Hauer
2026-08-21 11:23         ` Luca Lauro
2026-08-13 15:26 ` [PATCH v4 02/14] ARM: mvebu: enable RN102 in mvebu_defconfig Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 03/14] ARM: mvebu: improve Netgear RN104 support Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 04/14] ARM: mvebu: rename PUTC_LL to MVEBU_PUTC_LL Luca Lauro via B4 Relay
2026-08-21 10:38   ` Sascha Hauer [this message]
2026-08-21 12:26     ` Luca Lauro
2026-08-13 15:26 ` [PATCH v4 05/14] drivers: fan: add fan subsystem, core API and G76x fan controller driver Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 06/14] commands: add fan control command Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 07/14] usb: ehci: add Marvell EHCI host controller driver Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 08/14] usb: ehci: initialize periodic_queue_dma Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 09/14] ata: ahci: add PCI AHCI and Marvell 9170 controller support Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 10/14] ata: ahci: fix zero-length DMA handling Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 11/14] ata: ahci: add helper for ATA commands without data Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 12/14] ata: ahci: improve AHCI port bring-up sequence Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 13/14] ata: ahci: add FLUSH EXT and STANDBY IMMEDIATE support during shutdown Luca Lauro via B4 Relay
2026-08-13 15:26 ` [PATCH v4 14/14] ata: ahci: cleanup legacy code and remove unused paths Luca Lauro via B4 Relay

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2e8bdbc7-5a4f-4dcf-8703-a0683424d418@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    --cc=devnull+famlauro93l.gmail.com@kernel.org \
    --cc=famlauro93l@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox