mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node
@ 2023-01-09 11:09 Ahmad Fatoum
  2023-01-09 11:09 ` [PATCH 2/3] fixup! Rename struct device_d to device Ahmad Fatoum
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Ahmad Fatoum @ 2023-01-09 11:09 UTC (permalink / raw)
  To: barebox; +Cc: Ahmad Fatoum

  - Out-of-tree patches often add a board driver, which may use the
    old device_d/driver_d naming. Especially with bisecting, this can
    be a hassle

  - We may split up some parts of struct device into a new
    struct platform_device like Linux does and we don't want
    to break out of tree patches twice.

Thus add the old names as aliases for now.

Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
---
 include/driver.h | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/include/driver.h b/include/driver.h
index 693d5cb3e580..c789f3151e70 100644
--- a/include/driver.h
+++ b/include/driver.h
@@ -74,7 +74,10 @@ struct device {
 	struct list_head cdevs;
 
 	const struct platform_device_id *id_entry;
-	struct device_node *of_node;
+	union {
+		struct device_node *device_node;
+		struct device_node *of_node;
+	};
 
 	const struct of_device_id *of_id_entry;
 
-- 
2.30.2




^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2023-01-10 14:45 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-01-09 11:09 [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node Ahmad Fatoum
2023-01-09 11:09 ` [PATCH 2/3] fixup! Rename struct device_d to device Ahmad Fatoum
2023-01-09 11:09 ` [PATCH 3/3] fixup! Rename struct driver_d to driver Ahmad Fatoum
2023-01-10 14:44 ` [PATCH 1/3] fixup! Rename device_d::device_node to device_d::of_node Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox