mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Michael Riesch <michael.riesch@wolfvision.net>
To: Sascha Hauer <sha@pengutronix.de>
Cc: barebox@lists.infradead.org, Frank Wunderlich <frank-w@public-files.de>
Subject: Re: [PATCH v2 6/7] arm: rockchip: rk3568: refactor common rk3568_start method
Date: Wed, 21 Sep 2022 13:57:25 +0200	[thread overview]
Message-ID: <f78a05c7-3142-626c-3b02-f969c729b40f@wolfvision.net> (raw)
In-Reply-To: <20220921091724.GB986@pengutronix.de>

Hi Sascha,

On 9/21/22 11:17, Sascha Hauer wrote:
> On Mon, Sep 19, 2022 at 01:39:47PM +0200, Michael Riesch wrote:
>> After the removal of the IO domain configuration code, the low-level
>> initialization is the same for all RK356x boards. Add a common
>> method rk3568_start to remove this code duplication.
>>
>> Signed-off-by: Michael Riesch <michael.riesch@wolfvision.net>
>> ---
>>  arch/arm/boards/pine64-quartz64/lowlevel.c    | 30 +----------------
>>  arch/arm/boards/radxa-rock3/lowlevel.c        | 27 ---------------
>>  .../arm/boards/rockchip-rk3568-evb/lowlevel.c | 33 +------------------
>>  .../arm/mach-rockchip/include/mach/rockchip.h |  1 +
>>  arch/arm/mach-rockchip/rk3568.c               | 24 ++++++++++++++
>>  5 files changed, 27 insertions(+), 88 deletions(-)
>>
>> diff --git a/arch/arm/boards/pine64-quartz64/lowlevel.c b/arch/arm/boards/pine64-quartz64/lowlevel.c
>> index b295885522..e1beb3e624 100644
>> --- a/arch/arm/boards/pine64-quartz64/lowlevel.c
>> +++ b/arch/arm/boards/pine64-quartz64/lowlevel.c
>> @@ -1,39 +1,11 @@
>>  // SPDX-License-Identifier: GPL-2.0-only
>>  #include <common.h>
>> -#include <linux/sizes.h>
>> -#include <asm/barebox-arm-head.h>
>>  #include <asm/barebox-arm.h>
>> -#include <mach/hardware.h>
>> -#include <mach/atf.h>
>> -#include <debug_ll.h>
>>  #include <mach/rockchip.h>
>>  
>>  extern char __dtb_rk3566_quartz64_a_start[];
>>  
>> -static noinline void start_quartz64(void *fdt)
>> -{
>> -	/*
>> -	 * Image execution starts at 0x0, but this is used for ATF and
>> -	 * OP-TEE later, so move away from here.
>> -	 */
>> -	if (current_el() == 3)
>> -		relocate_to_adr_full(RK3568_BAREBOX_LOAD_ADDRESS);
>> -	else
>> -		relocate_to_current_adr();
>> -
>> -	setup_c();
>> -
>> -	if (current_el() == 3) {
>> -		rk3568_lowlevel_init();
>> -		rk3568_atf_load_bl31(fdt);
>> -		/* not reached */
>> -	}
>> -
>> -	barebox_arm_entry(RK3568_DRAM_BOTTOM, 0x80000000 - RK3568_DRAM_BOTTOM,
>> -			  fdt);
>> -}
>> -
>>  ENTRY_FUNCTION(start_quartz64a, r0, r1, r2)
>>  {
>> -	start_quartz64(__dtb_rk3566_quartz64_a_start);
>> +	rk3568_start(__dtb_rk3566_quartz64_a_start);
>>  }
> 
> Here __dtb_rk3566_quartz64_a_start is accessed before setup_c() has been
> called. That is not allowed, see the patch I just sent.

Does the refactoring make sense to you in general? Can I change it to

ENTRY_FUNCTION(start_my_fancy_board, r0, r1, r2)
{
	setup_c();
	rk3568_start(__dtb_my_fancy_board_start);
}

?

> BTW this patch breaks compilation, which is only fixed in 7/7:
> 
> /ptx/work/WORK_EIHEI/sha/projects/barebox/barebox/arch/arm/boards/rockchip-rk3568-bpi-r2pro/lowlevel.c:14:22: error: conflicting types for 'rk3568_start'
>    14 | static noinline void rk3568_start(void)
>       |                      ^~~~~~~~~~~~
> In file included from /ptx/work/WORK_EIHEI/sha/projects/barebox/barebox/arch/arm/boards/rockchip-rk3568-bpi-r2pro/lowlevel.c:10:
> /ptx/work/WORK_EIHEI/sha/projects/barebox/barebox/arch/arm/mach-rockchip/include/mach/rockchip.h:37:6: note: previous declaration of 'rk3568_start' was here
>    37 | void rk3568_start(void *fdt);
>       |      ^~~~~~~~~~~~

Oops. The goal was to separate the changes that affect the BananaPi, but
in this case 6 + 7 need to be squashed. I guess Frank needs to object to
the combined patch if it breaks something on his side.

Best regards,
Michael



  reply	other threads:[~2022-09-21 11:59 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-09-19 11:39 [PATCH v2 0/7] soc: rockchip: add driver for rockchip io domains Michael Riesch
2022-09-19 11:39 ` [PATCH v2 1/7] " Michael Riesch
2022-09-21  9:46   ` Sascha Hauer
2022-09-21 11:49     ` Michael Riesch
2022-09-22  8:03       ` Sascha Hauer
2022-09-22  8:13         ` Ahmad Fatoum
2022-09-22  8:23           ` Sascha Hauer
2022-09-19 11:39 ` [PATCH v2 2/7] arm: rockchip_v8_defconfig: enable io domain driver Michael Riesch
2022-09-19 11:39 ` [PATCH v2 3/7] arm: rockchip: radxa-rock3: remove io domain configuration Michael Riesch
2022-09-19 11:39 ` [PATCH v2 4/7] arm: rockchip: rk3568-evb: " Michael Riesch
2022-09-19 11:39 ` [PATCH v2 5/7] arm: rockchip: rk3568-bpi-r2pro: " Michael Riesch
2022-09-19 11:39 ` [PATCH v2 6/7] arm: rockchip: rk3568: refactor common rk3568_start method Michael Riesch
2022-09-21  9:17   ` Sascha Hauer
2022-09-21 11:57     ` Michael Riesch [this message]
2022-09-21 12:21       ` Sascha Hauer
2022-09-21 12:34         ` Michael Riesch
2022-09-19 11:39 ` [PATCH v2 7/7] arm: rockchip: rk3568-bpi-r2pro: use common method rk3568_start Michael Riesch

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f78a05c7-3142-626c-3b02-f969c729b40f@wolfvision.net \
    --to=michael.riesch@wolfvision.net \
    --cc=barebox@lists.infradead.org \
    --cc=frank-w@public-files.de \
    --cc=sha@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox